How to Fix Redsn0w Stuck on “Waiting for Reboot” Issue for iPhone and iPod Touch

Written By Sam on 8 October 2010
Advertisements

The iPhone DevTeam has released RedSn0w 0.9.6 beta for Windows to jailbreak iOS 4.1 on iPhone 3G and iPod Touch 2G. The Dev-Team has earlier released redsn0w 0.9.6 for Mac OS X. Redsn0w can also be used to jailbreak iOS 4.0 on iPhone 3G and iPod Touch 2G. Redsn0w can also be used to jailbreak iOS 4.0 on iPhone 3G and iPod Touch 2G. Redsn0w 0.9.6b1 still uses the same pwnage2 DFU-mode exploit that the Dev team have been using since the 2.x days. It does not include the SHAtter exploit developed by pod2g and nothing new is revealed to Apple with this jailbreak.

If you are an iPhone 3G or iPod Touch 2G you can read the jailbreaking guides below

Jailbreak iPhone 3G iOS 4.1 With Redsn0w 0.9.6 on Windows
Jailbreak iPod Touch 2G iOS 4.1 Using RedSn0w for Windows

There are some users who were facing “Waiting for Reboot” message while trying the above jailbreak methods. If you are one of those then try with the following things to solve the issue.

Redsn0w “Waiting for Reboot” Fix 1

  • Ensure that you are using the right IPSW file for your device.

Redsn0w “Waiting for Reboot” Fix 2

  • If you are running a 64bit OS then run the redsn0w tool in 32bit Windows XP compatible mode to see if the issue is solved.

Redsn0w “Waiting for Reboot” Fix 3

  • Keep redsn0w running, Unplug your device and Plug it back in. You might need to try this multiple times to make t work.

Redsn0w “Waiting for Reboot” Fix 4

  • Unplug USB cable from the computer and Plug it in a different USB port, preferably in a port closer to the computer and not to a hub.

2 Responses to “How to Fix Redsn0w Stuck on “Waiting for Reboot” Issue for iPhone and iPod Touch”

  1. thufel says:

    it not work in my ipod touch 2g mc. pleaseeee help mee now 🙁

  2. Kevin says:

    Same can u send me more stuff i have a ipod touch 2gen 8g mc model. The firmware is Ipod2,1_4.1_8B117_Restore.ipsw.
    I folowed all the instruction, did a few unplug replug and still nothing happens

Leave your response!